Jetzt verfügbar:  Berichte für DRACOONMehr Infos

Incorrect Swagger reference in Branding API model SimpleImageResponse

Kommentare

3 Kommentare

  • Offizieller Kommentar
    Avatar
    Florian Scheuer

    Hi Sebastian,

    Thanks for contacting us.

    However, I'm not able to reproduce your issue (I analyzed Branding Service v. 1.3.1). Please note that we have two different GET APIs (for different purposes) that do not use identical models:

    GET /v1/branding (Model is UpdateBrandingResponse which contains a list of images with the model SimpleImageResponse) and GET /v1/public/branding (Model is CacheableBrandingResponse which contains a list of images with the model CacheableBrandingImageResponse). The latter is the response model you actually got in your snippets above; the former one is the one you expected.

    Documented models and actually returned models were the same in my tests. Did I miss something?

    Thanks for your support!
    Florian

    Aktionen für Kommentare Permalink
  • Hi Florian,

    you're absolutely right. Indeed, I missed that there are different models for images property in CacheableBrandingResponse and UpdateBrandingResponse. Your documentation in Swagger defines both models exactly as their corresponding actual response.

    TL;DR: My mistake, issue can be closed.

    Mea culpa,

    Sebastian

    0
    Aktionen für Kommentare Permalink
  • Avatar
    Florian Scheuer

    Hey Sebastian,

    never mind, glad to help!

    Cheers,
    Florian

    0
    Aktionen für Kommentare Permalink

Bitte melden Sie sich an, um einen Kommentar zu hinterlassen.